06 44 00 14 84 (ou 0033644001484)
villes

Vous êtes à la recherche de : Agence Prestashop Grenoble


Agence Prestashop Grenoble


APPELEZ NOUS : 0644001484


Article:

Polkit implique directement une bibliothèque logicielle libre souscrivant à l’interaction des applications avec des services privilégiés du système. À l’opposé d'autres créations permettant une augmentation des privilèges comme sudo, le processus ne se voit pas attribuer les droits super utilisateur, ce qui facilite un contrôle fin au niveau du système de ce que peuvent faire ou non les utilisateurs. Polkit fonctionne sur les systèmes de type UNIX et fait partie du projet freedesktop.org.
La sortie de la version 0.105 en avril 20122, a transformé le nom du projet, passant de PolicyKit à polkit, pour sauver la réécriture du projet et la modification de l'API, cassant de fait la compatibilité ascendante. Polkit est intégré aux distributions Ubuntu (depuis la version 8.04), Fedora (depuis la version 8), Mandriva (depuis la version 2008.1) et OpenSUSE (depuis la version 10.3).
Il ya des clients linux qui sont navrés par certains choix de PolicyKit. Linus Torvalds pense que les gens qui considèrent qu'il est nécessaire de demander le mot de passe super-utilisateur pour modifier l'heure d'un ordinateur ou pour configurer une imprimante sont des idiots3.
D'autres utilisateurs contestent le principe même de PolicyKit. Ces derniers estiment que sa fonctionnalité peut être implémentée sans utiliser les ressources système nécessaires pour le fonctionnement de PolicyKit. De plus, ils font découvrir que PolicyKit est tellement compliqué qu'il a été nécessaire de lui incorporer un interpréteur JavaScript afin de pouvoir le configurer, ce qui soulève de nouveaux problèmes de sécurité et va ainsi à l'encontre du but recherché4.
Le générateur principal de PolicyKit en la personne de David Zeuthen, justifie l'inclusion d'un interpréteur JavaScript en écrivant qu'il serait bien, face à l'incapacité de produire une configuration qui satisfasse tous les utilisateurs, de procurer une solution pour résoudre les problèmes exposés lors de l'utilisation de PolicyKit, problèmes qui font qu'il n'a jamais bien fonctionné. En clair, nous exigeons une sorte de langage de programmation
Performance Application Programming Interface (PAPI) symbolise une interface de programmation portable (sous la forme d'une bibliothèque logicielle) permettant de rapprocher les compteurs matériels spécifiques aux microprocesseurs modernes. PAPI est utilisé pour coaliser des informations de bas niveau (telles que le nombre d'opérations en virgule flottantes FLOPS par seconde, le nombre de cache misses durant l'exécution d'un code, etc..). PAPI est interfacé avec les systèmes d'exploitation de type UNIX.
Présentement, la bibliothèque PAPI est à mesure d'aborder les compteurs matériels de la plupart des processeurs modernes. La liste des processeurs non reconnu ne cesse de réduire.